Codes from my life

I had recently bought MTS connection which gave a usb stick to connect it. It also gave a rpm for the GUI. Later I found that due to it, some software like vlc and skype had stopped working.

I used to get errors like this:

roshan@localhost:~/Downloads$ vlc
VLC media player 1.1.3 The Luggage (revision exported)
Blocked: call to unsetenv("DBUS_ACTIVATION_ADDRESS")
Blocked: call to unsetenv("DBUS_ACTIVATION_BUS_TYPE")
Warning: call to signal(13, 0x1)
[0x9e9c8fc] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[0xa02ba9c] skins2 interface error: no suitable dialogs provider found (hint: compile the qt4 plugin, and make sure it is loaded properly)
[0xa02ba9c] skins2 interface error: cannot instanciate qt4 dialogs provider
[0x9e9c8fc] main libvlc error: interface "default" initialization failed


roshan@localhost:~/Downloads$ skype
Fatal: Cannot mix incompatible Qt libraries
Aborted (core dumped)

The problem was with the linking of Qt libraries.
roshan@localhost:~/Downloads$ ldd /usr/bin/skype |grep -i Qt
libQtDBus.so.4 => /usr/lib/libQtDBus.so.4 (0x00406000)
libQtGui.so.4 => /usr/local/bin/ztemtApp/bin/libQtGui.so.4 (0x00efa000)
libQtNetwork.so.4 => /usr/lib/libQtNetwork.so.4 (0x002eb000)
libQtCore.so.4 => /usr/local/bin/ztemtApp/bin/libQtCore.so.4 (0x0084e000)
libQtXml.so.4 => /usr/lib/libQtXml.so.4 (0x00122000)

The libraries installed by the MTS stick had screwed the system. Notice that libQtGui links to /usr/local/bin/ztemtApp/bin/libQtGui.so.4.

So since I had forgotten which rpm had installed it I simply moved /usr/local/bin/ztemtApp/ to some location not in my path and things were back to normal.

roshan@localhost:~/Downloads$ ldd /usr/bin/skype |grep -i Qt
libQtDBus.so.4 => /usr/lib/libQtDBus.so.4 (0x00e24000)
libQtGui.so.4 => /usr/lib/libQtGui.so.4 (0x00eff000)
libQtNetwork.so.4 => /usr/lib/libQtNetwork.so.4 (0x002eb000)
libQtCore.so.4 => /usr/lib/libQtCore.so.4 (0x073ae000)
libQtXml.so.4 => /usr/lib/libQtXml.so.4 (0x00d1a000)

Advertisements

Comments on: "Problem due to incompatible Qt versions" (5)

  1. hello,
    I’m having exactly the same problem,i’m getting a vlc run-time error in ubuntu similar to yours,i’m new to ubuntu and didn’t understand your explanation.can you please list the steps,thank you

    • Essentially it means that you have two versions on Qt installed, so remove the one that you have installed from MTS or rather any other provider. Otherwise it wont work.

      Also its better to use network manager for connecting to internet using USB dongles.

  2. ok i’m programming vlc player,there is already a qt installed in this system,so i’m getting the error while i run vlc because of that,so if i uninstall the previously installed qt,i’ll not have the errors,is that correct?

    • What do you mean by “programming vlc” ? BTW you should not uninstall the version which was installed by your package manager, else it may screw up your system.

      • “programming vlc” – i’m just trying to modify the source code of vlc player, which is required for my company’s project,then you have said something about changing location,can you explain, i’m new to this

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: